summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDemis Balbach <db@minikn.xyz>2023-02-23 12:48:22 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-05 23:06:55 +0100
commit626205fbff7a1da34b33150d615438e5e9a6cabb (patch)
tree1d62aa35970bd9141041e46d5a308c5a831ef7e3
parentde45676c2a4c4c04b2a172c05af78a5f1ded5636 (diff)
downloadguix-patches-626205fbff7a1da34b33150d615438e5e9a6cabb.tar
guix-patches-626205fbff7a1da34b33150d615438e5e9a6cabb.tar.gz
gnu: Add evdi.
* gnu/packages/linux.scm (evdi): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm30
1 files changed, 29 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 8e01d505ab..e5129b0c6f 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -68,7 +68,7 @@
;;; Copyright © 2022 Hunter Jozwiak <hunter.t.joz@gmail.com>
;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;; Copyright © 2022 Stefan <stefan-guix@vodafonemail.de>
-;;; Copyright © 2022 Demis Balbach <db@minikn.xyz>
+;;; Copyright © 2022, 2023 Demis Balbach <db@minikn.xyz>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -1492,6 +1492,34 @@ backlight only models are currently not supported. The @code{tuxedo_io} module
is also needed for the @code{tuxedo-control-center} (short tcc) package.")
(license license:gpl3+)))
+(define-public evdi
+ (package
+ (name "evdi")
+ (version "1.12.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DisplayLink/evdi")
+ (commit "bdc258b25df4d00f222fde0e3c5003bf88ef17b5")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yi7mbyvxm9lsx6i1xbwp2bihwgzhwxkydk1kbngw5a5kw9azpws"))))
+ (build-system linux-module-build-system)
+ (arguments
+ (list #:tests? #f ;no test suite
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "module"))))))
+ (home-page "https://github.com/DisplayLink/evdi")
+ (synopsis "EVDI Linux kernel module")
+ (description
+ "The @acronym{EVDI, Extensible Virtual Display Interface} is a Linux kernel module
+that enables management of multiple screens, allowing user-space programs to
+take control over what happens with the image.")
+ (license license:gpl2)))
+
(define-public ec
(package
(name "ec")