summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDemis Balbach <db@minikn.xyz>2023-02-23 12:48:22 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-05 23:06:55 +0100
commit559732e42ba0c088576c598df3f130c97477ab67 (patch)
treeb5e0c9afa549a07148b957594664601ee292faa5
parent626205fbff7a1da34b33150d615438e5e9a6cabb (diff)
downloadguix-patches-559732e42ba0c088576c598df3f130c97477ab67.tar
guix-patches-559732e42ba0c088576c598df3f130c97477ab67.tar.gz
gnu: Add libevdi.
* gnu/packages/linux.scm (libevdi): New variables. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/linux.scm36
1 files changed, 36 insertions, 0 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index e5129b0c6f..a53583cc51 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -9711,6 +9711,42 @@ older system-wide @file{/sys} interface.")
libraries are found or why they cannot be located.")
(license license:expat)))
+(define-public libevdi
+ (package
+ (name "libevdi")
+ (version "1.12.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/DisplayLink/evdi")
+ (commit "bdc258b25df4d00f222fde0e3c5003bf88ef17b5")))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1yi7mbyvxm9lsx6i1xbwp2bihwgzhwxkydk1kbngw5a5kw9azpws"))))
+ (build-system gnu-build-system)
+ (inputs (list libdrm))
+ (arguments
+ (list #:tests? #f ;no test suite
+ #:make-flags #~'("CC=gcc")
+ #:phases #~(modify-phases %standard-phases
+ (delete 'configure)
+ (add-after 'unpack 'chdir
+ (lambda _
+ (chdir "library")))
+ (replace 'install
+ (lambda* _
+ (let* ((lib (string-append #$output "/lib")))
+ (mkdir-p lib)
+ (install-file "libevdi.so" lib)))))))
+ (home-page "https://github.com/DisplayLink/evdi")
+ (synopsis "User-space EVDI library")
+ (description
+ "Libevdi is a library that gives applications easy access to
+@acronym{EVDI, Extensible Virtual Display Interface} devices on
+various operating systems.")
+ (license license:lgpl2.1)))
+
(define-public touchegg
(package
(name "touchegg")