summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPreston M. Firestone <firestone.preston@gmail.com>2023-02-17 23:45:42 -0600
committerLudovic Courtès <ludo@gnu.org>2023-03-04 18:46:37 +0100
commit173a42b487c84ddcbe2eb5897efdddd16b8a7b45 (patch)
treeedaddb55eea249a7f1d9aeeb933e8d780753b5f8
parent0d6c5e0ba1bd6800712e79964f7b9f5c6043f249 (diff)
downloadguix-patches-173a42b487c84ddcbe2eb5897efdddd16b8a7b45.tar
guix-patches-173a42b487c84ddcbe2eb5897efdddd16b8a7b45.tar.gz
gnu: gambit-c: Update gambit-c to 4.9.4.
* gnu/packages/scheme.scm (gambit-c): Update to 4.9.4. [uri]: change source URL to http://www.gambitscheme.org/. [home-page]: update URL to the project's new home page. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/scheme.scm10
1 files changed, 5 insertions, 5 deletions
diff --git a/gnu/packages/scheme.scm b/gnu/packages/scheme.scm
index ddf77c53c6..e6a9ef1db0 100644
--- a/gnu/packages/scheme.scm
+++ b/gnu/packages/scheme.scm
@@ -544,24 +544,24 @@ in Scheme, and a runtime library which allows Pre-Scheme code to run as Scheme."
(define-public gambit-c
(package
(name "gambit-c")
- (version "4.9.3")
+ (version "4.9.4")
(source
(origin
(method url-fetch)
(uri (string-append
- "http://www.iro.umontreal.ca/~gambit/download/gambit/v"
- (version-major+minor version) "/source/gambit-v"
+ "http://www.gambitscheme.org/"
+ version "/gambit-v"
(string-map (lambda (c) (if (char=? c #\.) #\_ c)) version)
".tgz"))
(sha256
- (base32 "1p6172vhcrlpjgia6hsks1w4fl8rdyjf9xjh14wxfkv7dnx8a5hk"))))
+ (base32 "025x8zi9176qwww4d3pk8aj9ab1fpqyxqz26q3v394k6bfk49yqr"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags
;; According to the ./configure script, this makes the build slower and
;; use >= 1 GB memory, but makes Gambit much faster.
'("--enable-single-host")))
- (home-page "http://dynamo.iro.umontreal.ca/wiki/index.php/Main_Page")
+ (home-page "http://www.gambitscheme.org/")
(synopsis "Efficient Scheme interpreter and compiler")
(description
"Gambit consists of two main programs: gsi, the Gambit Scheme