summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGiacomo Leidi <goodoldpaul@autistici.org>2023-01-04 15:21:48 +0100
committerChristopher Baines <mail@cbaines.net>2023-03-01 15:14:36 +0000
commita0da11ee473c1ec9abb43a1e36d5a9dd2906d828 (patch)
tree53c830bb6b52a60a7944484730614c1bd0e44c03
parentfbcc42ad6c22ef7257daede968ff2b8d41bdd30d (diff)
downloadguix-patches-a0da11ee473c1ec9abb43a1e36d5a9dd2906d828.tar
guix-patches-a0da11ee473c1ec9abb43a1e36d5a9dd2906d828.tar.gz
gnu: Add python-pypresence.
* gnu/packages/messaging.scm (python-pypresence): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/messaging.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/messaging.scm b/gnu/packages/messaging.scm
index d540309a8f..5020146300 100644
--- a/gnu/packages/messaging.scm
+++ b/gnu/packages/messaging.scm
@@ -37,6 +37,7 @@
;;; Copyright © 2022 Jack Hill <jackhill@jackhill.us>
;;; Copyright © 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2022 Giovanni Biscuolo <g@xelera.eu>
+;;; Copyright © 2023 Giacomo Leidi <goodoldpaul@autistici.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3460,6 +3461,23 @@ Discord.")
(home-page "https://github.com/taylordotfish/harmony")
(license license:gpl3+)))
+(define-public python-pypresence
+ (package
+ (name "python-pypresence")
+ (version "4.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "pypresence" version))
+ (sha256
+ (base32
+ "0rp09lfxbc3syd1rhbai2516c3wyfxkzrsw8v4bd57qqr2cay7b9"))))
+ (build-system python-build-system)
+ (home-page "https://github.com/qwertyquerty/pypresence")
+ (synopsis "Discord RPC client")
+ (description "This package provides @code{python-pypresence}, a Discord
+RPC client written in Python.")
+ (license license:expat)))
+
(define-public pn
(package
(name "pn")