summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2022-12-23 19:32:59 +0100
committerChristopher Baines <mail@cbaines.net>2023-03-01 15:14:35 +0000
commit722073b151da3f42d4e2d24fadcac561ed428a52 (patch)
tree5a08aa0fe7dc8b5ecc6f99447e9de5f40fe27576
parentf9abf24f242348db4af469c567f58b62cc181b2a (diff)
downloadguix-patches-722073b151da3f42d4e2d24fadcac561ed428a52.tar
guix-patches-722073b151da3f42d4e2d24fadcac561ed428a52.tar.gz
gnu: Add python-pixelmatch.
* gnu/packages/python-xyz.scm (python-pixelmatch): New variable. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/python-xyz.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ed1832730e..f2e107fae2 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -7699,6 +7699,26 @@ a general image processing tool.")
(description "This package is a fork of Pillow which adds support for SIMD
parallelism.")))
+(define-public python-pixelmatch
+ (package
+ (name "python-pixelmatch")
+ (version "0.3.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "pixelmatch" version))
+ (sha256
+ (base32 "16b0cz136dcmj4dbr505igpql8dmqmr9vni5nbaa5kygjfjkdynh"))))
+ (build-system python-build-system)
+ (native-inputs (list python-pillow))
+ (home-page "https://github.com/whtsky/pixelmatch-py")
+ (synopsis "A pixel-level image comparison library")
+ (description "This package provides a pixel-level image comparison library
+for Python, originally created to compare screenshots in tests. Its features
+include accurate anti-aliased pixels detection and perceptual color difference
+metrics.")
+ (license license:isc)))
+
(define-public python-imagecodecs
(package
(name "python-imagecodecs")