summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-03-01 08:23:37 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-02 00:08:11 +0100
commit242c3e9300a8e3263c1c9733d4bb79dbddc77767 (patch)
tree6570639bb38457f95e24942560c98064caf3089d
parentf0f5f011974d82de12b7db849f4658a8dd0f207e (diff)
downloadguix-patches-242c3e9300a8e3263c1c9733d4bb79dbddc77767.tar
guix-patches-242c3e9300a8e3263c1c9733d4bb79dbddc77767.tar.gz
gnu: Add r-biglm.
* gnu/packages/cran.scm (r-biglm): New variable. Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index a74432a29f..147af98836 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1165,6 +1165,29 @@ The package provides functions for point generation, arc length estimation,
degree elevation and curve fitting.")
(license license:gpl2+)))
+(define-public r-biglm
+ (package
+ (name "r-biglm")
+ (version "0.9-2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "biglm" version))
+ (sha256
+ (base32 "0iy9xr2bq42wlizgwlz7w5kh9206yqkw9h2cr6mcsmizgjg3rkvd"))))
+ (properties `((upstream-name . "biglm")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-dbi))
+ (native-inputs (list gfortran))
+ (home-page "https://cran.r-project.org/package=biglm")
+ (synopsis "Bounded memory linear and generalized linear models")
+ (description "The biglm package lets you create a linear model object that
+uses only code{p^2} memory for @code{p} variables. It can be updated with
+more data using @code{update}. This allows linear regression on data sets
+larger than memory.")
+ ;; Expanded from GPL
+ (license (list license:gpl2+ license:gpl3+))))
+
(define-public r-bwstest
(package
(name "r-bwstest")