summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMădălin Ionel Patrașcu <madalinionel.patrascu@mdc-berlin.de>2023-02-27 11:28:45 +0100
committerRicardo Wurmus <rekado@elephly.net>2023-03-01 13:46:01 +0100
commit020e5ac362e3dbb578da40adeaa929a2f5fd3929 (patch)
tree6e9201f00eaf68eafbdbcbc5c01905943f02ae82
parentc7a25ee3de555f78b4726d9dc0693104ade32c92 (diff)
downloadguix-patches-020e5ac362e3dbb578da40adeaa929a2f5fd3929.tar
guix-patches-020e5ac362e3dbb578da40adeaa929a2f5fd3929.tar.gz
gnu: Add r-pagoda2.
* gnu/packages/cran.scm (r-pagoda2): New variable.
-rw-r--r--gnu/packages/cran.scm53
1 files changed, 53 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index d4acc8cfdc..5e69b7e3f6 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -2031,6 +2031,59 @@ consistent fashion. It seeks to combine functionality from lower level
functions which can speed up workflow.")
(license license:gpl2)))
+(define-public r-pagoda2
+ (package
+ (name "r-pagoda2")
+ (version "1.0.10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "pagoda2" version))
+ (sha256
+ (base32 "18ip8j5l5c3hqw1xsf5wnyas55i2mhk09phy68kjkjdgcymmpg7c"))))
+ (properties `((upstream-name . "pagoda2")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-dendsort
+ r-drat
+ r-fastcluster
+ r-igraph
+ r-irlba
+ r-magrittr
+ r-mass
+ r-matrix
+ r-mgcv
+ r-n2r
+ r-plyr
+ r-r-utils
+ r-r6
+ r-rcpp
+ r-rcpparmadillo
+ r-rcppeigen
+ r-rcppprogress
+ r-rjson
+ r-rlang
+ r-rmtstat
+ r-rook
+ r-rtsne
+ r-sccore
+ r-urltools))
+ (home-page "https://github.com/kharchenkolab/pagoda2")
+ (synopsis "Single cell analysis and differential expression")
+ (description
+ "The package offers functions for analyzing and interactively exploring
+large-scale single-cell RNA-seq datasets. Pagoda2 primarily performs
+normalization and differential gene expression analysis, with an interactive
+application for exploring single-cell RNA-seq datasets. It performs basic
+tasks such as cell size normalization, gene variance normalization, and can be
+used to identify subpopulations and run differential expression within
+individual samples. pagoda2 was written to rapidly process modern large-scale
+scRNAseq datasets of approximately 1e6 cells. The companion web application
+allows users to explore which gene expression patterns form the different
+subpopulations within your data. The package also serves as the primary
+method for preprocessing data for conos.")
+ (license license:gpl3)))
+
(define-public r-pals
(package
(name "r-pals")