summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBruno Victal <mirai@makinata.eu>2023-02-27 16:14:55 +0000
committerChristopher Baines <mail@cbaines.net>2023-03-14 10:36:31 +0000
commit9baadac2b7bc9ad4b06e24a4e2f6e487dfea6080 (patch)
tree1d9b0df2d90ce570d9c908b610fc2b1e4648df8b
parent79ba6380cf4ea7064d5f232b0423a8b7d0ba953c (diff)
downloadguix-patches-9baadac2b7bc9ad4b06e24a4e2f6e487dfea6080.tar
guix-patches-9baadac2b7bc9ad4b06e24a4e2f6e487dfea6080.tar.gz
gnu: rng-tools: Rewrite using gexps.
* gnu/packages/linux.scm (rng-tools)[arguments]: Rewrite using gexps. Signed-off-by: Christopher Baines <mail@cbaines.net>
-rw-r--r--gnu/packages/linux.scm29
1 files changed, 15 insertions, 14 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f33c98d591..1046424c19 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -6686,20 +6686,21 @@ The collection contains a set of bandwidth and latency benchmark such as:
"0i00if7xknpm0dhkrm60rxzyyvq0vdibq7dvsd2ncm9pg098qvwj"))))
(build-system gnu-build-system)
(arguments
- `(;; Disable support for various hardware entropy sources as they need
- ;; dependencies that are not yet in Guix, and would significantly
- ;; increase closure size.
- #:configure-flags '("--without-nistbeacon"
- "--without-pkcs11"
- "--without-rtlsdr")
- #:phases
- (modify-phases %standard-phases
- (add-before 'check 'disable-failing-test
- (lambda _
- (substitute* "tests/Makefile"
- ;; This test requires a hwrng, rdrand, or tpm device.
- ;; Worse, it appears to fail if that isn't sufficiently random.
- (("\\brngtestjitter\\.sh\\b") " ")))))))
+ (list
+ ;; Disable support for various hardware entropy sources as they need
+ ;; dependencies that are not yet in Guix, and would significantly
+ ;; increase closure size.
+ #:configure-flags #~(list "--without-nistbeacon"
+ "--without-pkcs11"
+ "--without-rtlsdr")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'check 'disable-failing-test
+ (lambda _
+ (substitute* "tests/Makefile"
+ ;; This test requires a hwrng, rdrand, or tpm device.
+ ;; Worse, it appears to fail if that isn't sufficiently random.
+ (("\\brngtestjitter\\.sh\\b") " ")))))))
(native-inputs
(list autoconf automake pkg-config))
(inputs