summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJack Hill <jackhill@jackhill.us>2023-03-02 23:37:13 -0500
committerLudovic Courtès <ludo@gnu.org>2023-03-13 15:08:34 +0100
commit3e7dc94a140e8a230e91af5e57370932457e0946 (patch)
treec652cbc603443701fc133080a62b1cee701f0562
parentbc65415fb1fe998a873747ca8c5ae1f795ae71d3 (diff)
downloadguix-patches-3e7dc94a140e8a230e91af5e57370932457e0946.tar
guix-patches-3e7dc94a140e8a230e91af5e57370932457e0946.tar.gz
gnu: rnp: Improve package style.
* gnu/package/openpgp.scm (rnp)[phases]{fixes}: Rename fixes to patch-tests, use search-input-file, and remove trailing #t. {check}: Respect tests?. [native-inputs]: Remove labels. [home-page]: Update URL. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/openpgp.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/openpgp.scm b/gnu/packages/openpgp.scm
index 422e9bdcd6..9b6f04b407 100644
--- a/gnu/packages/openpgp.scm
+++ b/gnu/packages/openpgp.scm
@@ -118,23 +118,23 @@ environments.")
"-DDOWNLOAD_RUBYRNP=off")
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'fixes
- (lambda* (#:key inputs #:allow-other-keys)
+ (add-after 'unpack 'patch-tests
+ (lambda _
(substitute* "src/tests/support.cpp"
- (("\"cp\"") (string-append "\"" (which "cp") "\"")))
- #t))
+ (("\"cp\"") (search-input-file inputs "/bin/cp")))))
(replace 'check
- (lambda _
- ;; Some OpenPGP certificates used by the tests expire.
- ;; To work around that, set the time to roughly the
- ;; release date.
- (invoke "faketime" ,day-of-release "make" "test"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ ;; Some OpenPGP certificates used by the tests expire.
+ ;; To work around that, set the time to roughly the
+ ;; release date.
+ (invoke "faketime" ,day-of-release "make" "test")))))))
(native-inputs
- `(("gnupg" ,gnupg) ; for tests
- ("googletest" ,googletest)
- ("libfaketime" ,libfaketime) ; for tests
- ("pkg-config" ,pkg-config)
- ("python" ,python)))
+ (list gnupg ; for tests
+ googletest ; for tests
+ libfaketime ; for tests
+ pkg-config
+ python))
(inputs (list botan bzip2 json-c zlib))
(synopsis
"RFC4880-compliant OpenPGP library written in C++")
@@ -146,7 +146,7 @@ NetPGP, itself originally written for NetBSD.
librnp is the library used by rnp for all OpenPGP functions, useful for
developers to build against. It is a “real” library, not a wrapper like GPGME
of GnuPG.")
- (home-page "https://www.rnpgp.com/")
+ (home-page "https://www.rnpgp.org/")
(license
;; RNP contains code written by Ribose and code derived from netpgp.
(list