summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-11-17 12:54:58 +0200
committerEfraim Flashner <efraim@flashner.co.il>2022-11-17 13:05:52 +0200
commit211a1a6b44989689deb20ee1610283c89c917c75 (patch)
treef3b032e3f657bb53cd51748edc6645e4bfaeac36
parentdaa5da2bded086f4f905f158bc547979a3bc643f (diff)
downloadguix-patches-211a1a6b44989689deb20ee1610283c89c917c75.tar
guix-patches-211a1a6b44989689deb20ee1610283c89c917c75.tar.gz
gnu: giara: Update to 1.0.1.
* gnu/packages/syndication.scm (giara): Update to 1.0.1. [source]: Remove patch. [arguments]: Add phase to skip meson post-install script. [native-inputs]: Remove libxml2. Replace gtk+:bin with gtk:bin. [inputs]: Remove python-pycairo, webkitgtk-with-libsoup2. Add blueprint-compiler. Replace libhandy with libadwaita, gtk+ with gtk, python-mistune with python-mistune-next. [description]: Update. * gnu/packages/patches/giara-fix-login.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/giara-fix-login.patch27
-rw-r--r--gnu/packages/syndication.scm30
3 files changed, 15 insertions, 43 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 4fcaa6801a..b154caaaaa 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1196,7 +1196,6 @@ dist_patch_DATA = \
%D%/packages/patches/ghostscript-no-header-id.patch \
%D%/packages/patches/ghostscript-no-header-uuid.patch \
%D%/packages/patches/ghostscript-no-header-creationdate.patch \
- %D%/packages/patches/giara-fix-login.patch \
%D%/packages/patches/glib-appinfo-watch.patch \
%D%/packages/patches/glib-networking-gnutls-binding.patch \
%D%/packages/patches/glib-networking-32-bit-time.patch \
diff --git a/gnu/packages/patches/giara-fix-login.patch b/gnu/packages/patches/giara-fix-login.patch
deleted file mode 100644
index f15caaf559..0000000000
--- a/gnu/packages/patches/giara-fix-login.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-From f4adc1f52d777cea3331b4acae0c3bdec4d0eb70 Mon Sep 17 00:00:00 2001
-From: Paper <paper@tilde.institute>
-Date: Fri, 12 Mar 2021 21:10:34 +0000
-Subject: [PATCH] fix login by removing everything after # from URL
-
----
- giara/__main__.py | 3 ++-
- 1 file changed, 2 insertions(+), 1 deletion(-)
-
-diff --git a/giara/__main__.py b/giara/__main__.py
-index 10b9ae2..d235332 100644
---- a/giara/__main__.py
-+++ b/giara/__main__.py
-@@ -53,8 +53,9 @@ class GApplication(Gtk.Application):
- def open(self, app, files, *args):
- target = files[0].get_uri()
- print(target)
-+ code = target.split('=')[-1].split('#')[0]
- get_authorized_client(
-- reddit=self._unauth_reddit, code=target.split('=')[-1]
-+ reddit=self._unauth_reddit, code=code
- )
- self.continue_activate(self._unauth_reddit)
-
---
-GitLab
-
diff --git a/gnu/packages/syndication.scm b/gnu/packages/syndication.scm
index 57f8b61502..599f5c10e1 100644
--- a/gnu/packages/syndication.scm
+++ b/gnu/packages/syndication.scm
@@ -164,7 +164,7 @@ cards.")
(define-public giara
(package
(name "giara")
- (version "0.3")
+ (version "1.0.1")
(source
(origin
(method git-fetch)
@@ -172,15 +172,17 @@ cards.")
(url "https://gitlab.gnome.org/World/giara")
(commit version)))
(file-name (git-file-name name version))
- ;; To fix authentication while adding accounts.
- (patches (search-patches "giara-fix-login.patch"))
(sha256
- (base32 "004qmkfrgd37axv0b6hfh6v7nx4pvy987k5yv4bmlmkj9sbqm6f9"))))
+ (base32 "00vmfghp9g8yzn2d1xjawz5a8bdwn1jl1k24mjaf4vlvdy4sg9l4"))))
(build-system meson-build-system)
(arguments
`(#:glib-or-gtk? #t
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'skip-icon-cache
+ (lambda _
+ (substitute* "meson_post_install.py"
+ (("gtk-update-icon-cache") "true"))))
(add-after 'glib-or-gtk-wrap 'wrap-paths
(lambda* (#:key outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -196,28 +198,26 @@ cards.")
`(("gettext" ,gettext-minimal)
("glib:bin" ,glib "bin")
("gobject-introspection" ,gobject-introspection)
- ("gtk+:bin" ,gtk+ "bin")
- ("pkg-config" ,pkg-config)
- ("xmllint" ,libxml2)))
+ ("gtk:bin" ,gtk "bin")
+ ("pkg-config" ,pkg-config)))
(inputs
- `(("glib" ,glib)
- ("gtk+" ,gtk+)
+ `(("blueprint-compiler" ,blueprint-compiler)
+ ("glib" ,glib)
+ ("gtk" ,gtk)
("gtksourceview" ,gtksourceview)
- ("libhandy" ,libhandy)
+ ("libadwaita" ,libadwaita)
("python" ,python)
("python-beautifulsoup" ,python-beautifulsoup4)
("python-dateutil" ,python-dateutil)
- ("python-mistune" ,python-mistune)
+ ("python-mistune" ,python-mistune-next)
("python-pillow" ,python-pillow)
("python-praw" ,python-praw)
- ("python-pycairo" ,python-pycairo)
("python-pygobject" ,python-pygobject)
- ("python-requests" ,python-requests)
- ("webkitgtk" ,webkitgtk-with-libsoup2)))
+ ("python-requests" ,python-requests)))
(propagated-inputs
(list dconf))
(synopsis "Client for Reddit")
- (description "Giara is a reddit app, built with Python, GTK and Handy.")
+ (description "Giara is a reddit app, built with Python, GTK4 and libadwaita.")
(home-page "https://giara.gabmus.org/")
(license license:gpl3+)))