summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomasz Jeneralczyk <tj@schwi.pl>2022-08-14 14:46:19 +0200
committerLudovic Courtès <ludo@gnu.org>2022-08-30 00:40:05 +0200
commite1ea628776e9a2b6e3c54256e959d04af9ee9513 (patch)
tree446fcd2dc93ad52946df74af2063812a1ecf8fa8
parent05246c691bd9843d190d4b4b7e116dc19fe20520 (diff)
downloadguix-patches-e1ea628776e9a2b6e3c54256e959d04af9ee9513.tar
guix-patches-e1ea628776e9a2b6e3c54256e959d04af9ee9513.tar.gz
gnu: Add python-xvfbwrapper.
* gnu/packages/python-check.scm (python-xvfbwrapper): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
-rw-r--r--gnu/packages/python-check.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index 7cc266fbce..d7a7a90706 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -15,6 +15,7 @@
;;; Copyright © 2021 Bonface Munyoki Kilyungi <me@bonfacemunyoki.com>
;;; Copyright © 2022 Malte Frank Gerdes <malte.f.gerdes@gmail.com>
;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
+;;; Copyright © 2022 Tomasz Jeneralczyk <tj@schwi.pl>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2373,3 +2374,24 @@ diagnostics to end up in your TAP output (as TAP diagnostics, YAML blocks, or
attachments).
@end itemize")
(license license:expat)))
+
+(define-public python-xvfbwrapper
+ (package
+ (name "python-xvfbwrapper")
+ (version "0.2.9")
+ (source (origin
+ (method url-fetch)
+ (uri (pypi-uri "xvfbwrapper" version))
+ (sha256
+ (base32
+ "097wxhvp01ikqpg1z3v8rqhss6f1vwr399zpz9a05d2135bsxx5w"))))
+ (build-system python-build-system)
+ (propagated-inputs (list xorg-server-for-tests))
+ (home-page "https://github.com/cgoldberg/xvfbwrapper")
+ (synopsis "Python module for controlling virtual displays with Xvfb")
+ (description
+ "Xvfb (X virtual framebuffer) is a display server implementing
+the X11 display server protocol. It runs in memory and does not require a
+physical display. Only a network layer is necessary. Xvfb is useful for
+running acceptance tests on headless servers.")
+ (license license:expat)))