summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-08-28 16:47:41 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-30 08:57:56 +0200
commitdbd5612c9045fe1d64ea01ee863163eebbe5748c (patch)
tree5aa4f379d5cf3bd44e841079ca3c2fb459787059
parent80a75c53570a7d4af3d30f441feff8bcce5aa53a (diff)
downloadguix-patches-dbd5612c9045fe1d64ea01ee863163eebbe5748c.tar
guix-patches-dbd5612c9045fe1d64ea01ee863163eebbe5748c.tar.gz
gnu: python-path: Don't ask to run tests when cross-compiling.
* gnu/packages/python-xyz.scm (python-path)[arguments]{#:tests?}: When cross-compiling, set to #false. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 8843d10638..d5d15bb46c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12382,7 +12382,7 @@ invoked on those path objects directly.")
(substitute-keyword-arguments
(package-arguments python-path-bootstrap)
((#:tests? _ #f)
- #t)
+ (not (%current-target-system)))
((#:phases phases #~%standard-phases)
#~(modify-phases #$phases
(replace 'check