summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-08-28 16:47:46 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-30 08:57:57 +0200
commitd8b960983da9aeeb9a69d73f446b89cef778f546 (patch)
treea81f746c386a2a8cdf3b913cc6a94f162798386c
parentd720aa4a88c77d1ba84c05e404ceae8589d9c110 (diff)
downloadguix-patches-d8b960983da9aeeb9a69d73f446b89cef778f546.tar
guix-patches-d8b960983da9aeeb9a69d73f446b89cef778f546.tar.gz
gnu: ruby-rubocop: Don't ask to run tests when cross-compiling.
* gnu/packages/ruby.scm (ruby-rubocop)[arguments]{#:tests?}: When cross-compiling, set to #false. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/ruby.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index a37a8dda24..d2c2a931a1 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7211,7 +7211,8 @@ run.")
(arguments
`(#:test-target "default"
;; TODO: Figure out why test hangs.
- #:tests? ,(not (target-riscv64?))
+ #:tests? ,(not (or (%current-target-system)
+ (target-riscv64?)))
#:phases
(modify-phases %standard-phases
(add-before 'check 'set-home