summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-08-28 16:47:45 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-30 08:57:57 +0200
commitd720aa4a88c77d1ba84c05e404ceae8589d9c110 (patch)
tree496ff99de506caa59e596bd5aa72bc4251507c80
parent321620d15ba0400be0253c0423aea633d374ab7b (diff)
downloadguix-patches-d720aa4a88c77d1ba84c05e404ceae8589d9c110.tar
guix-patches-d720aa4a88c77d1ba84c05e404ceae8589d9c110.tar.gz
gnu: python-jaraco-context: Don't ask to run tests when cross-compiling.
* gnu/packages/python-xyz.scm (python-jaraco-context)[arguments]{#:tests?}: When cross-compiling, set to #false. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7a91321528..9b3d5edb93 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -8255,7 +8255,7 @@ procedures.")
(substitute-keyword-arguments
(package-arguments python-jaraco-context-bootstrap)
((#:tests? _ #f)
- #t)
+ (not (%current-target-system)))
((#:phases phases #~%standard-phases)
#~(modify-phases #$phases
(replace 'check