summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-08-28 16:47:36 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-30 08:57:55 +0200
commitd38a0024710d83d829a1057b9445c7864346c73c (patch)
tree6716aa7eea6e57eb8aa5eeac76f038deee85a044
parenta282c9844cd53d6a53b29ad740a95a39a30c1106 (diff)
downloadguix-patches-d38a0024710d83d829a1057b9445c7864346c73c.tar
guix-patches-d38a0024710d83d829a1057b9445c7864346c73c.tar.gz
gnu: julia-forwarddiff: Don't ask to run tests when cross-compiling.
* gnu/packages/julia-xyz.scm (julia-forwarddiff)[arguments]{#:tests?}: When cross-compiling, set to #false. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index a0adde6435..4fa711b808 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2049,7 +2049,8 @@ c-style numerical formatting.")
;; Expression: dual_isapprox(FDNUM ^ PRIMAL, exp(PRIMAL * log(FDNUM)))
;; ERROR: LoadError: LoadError: There was an error during testing
;; Disable as stopgap.
- (list #:tests? (not (target-x86-32?))))
+ (list #:tests? (not (or (%current-target-system)
+ (target-x86-32?)))))
(inputs ;required for tests
(list julia-calculus
julia-difftests))