summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-08-28 16:47:35 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-30 08:57:55 +0200
commita282c9844cd53d6a53b29ad740a95a39a30c1106 (patch)
tree246c072054e6d6ea3fc1a97d772d02d335b35570
parent81681f2d4a5fadb215488b39e6812c36d687f616 (diff)
downloadguix-patches-a282c9844cd53d6a53b29ad740a95a39a30c1106.tar
guix-patches-a282c9844cd53d6a53b29ad740a95a39a30c1106.tar.gz
gnu: julia-arrayinterface: Don't ask to run tests when cross-compiling.
* gnu/packages/julia-xyz.scm (julia-arrayinterface)[arguments]{#:tests?}: When cross-compiling, set to #false. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index e5b159245c..a0adde6435 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -165,7 +165,8 @@ provides functions to run a few automatable checks for Julia packages.")
;; Expression: @inferred(ArrayInterface.size(Rnr)) === (StaticInt(4),)
;; Evaluated: (static(2),) === (static(4),)
;; Disable as stopgap.
- (list #:tests? (not (target-x86-32?))))
+ (list #:tests? (not (or (%current-target-system)
+ (target-x86-32?)))))
(propagated-inputs
(list julia-ifelse
julia-requires