summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-08-28 16:47:40 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-30 08:57:56 +0200
commit80a75c53570a7d4af3d30f441feff8bcce5aa53a (patch)
treea6cc0cacc295de05feea4c903da60dcf453a5afc
parent0168c65de4ec9f25d5de76998474bedfd2baa7a0 (diff)
downloadguix-patches-80a75c53570a7d4af3d30f441feff8bcce5aa53a.tar
guix-patches-80a75c53570a7d4af3d30f441feff8bcce5aa53a.tar.gz
gnu: python-fonttools-full: Don't ask to run tests when cross-compiling.
* gnu/packages/python-xyz.scm (python-fonttools-full)[arguments]{#:tests?}: When cross-compiling, set to #false. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/python-xyz.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 1907b863ff..8843d10638 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -11305,7 +11305,7 @@ from an XML-based format.")
(arguments
(substitute-keyword-arguments (package-arguments python-fonttools)
((#:tests? _ #f)
- #t)
+ (not (%current-target-system)))
((#:phases phases '%standard-phases)
`(modify-phases ,phases
(replace 'check