summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxime Devos <maximedevos@telenet.be>2022-08-28 16:47:38 +0200
committerMathieu Othacehe <othacehe@gnu.org>2022-08-30 08:57:56 +0200
commit5192bead3266784d9bc98cc7a0522cf7580f175c (patch)
tree71c22852b73c719f8b59e6350c16c8a4e040a3d9
parent55e88a27592b5b453df9511fe55d9311e2895efd (diff)
downloadguix-patches-5192bead3266784d9bc98cc7a0522cf7580f175c.tar
guix-patches-5192bead3266784d9bc98cc7a0522cf7580f175c.tar.gz
gnu: julia-interpolations: Don't ask to run tests when cross-compiling.
* gnu/packages/julia-xyz.scm (julia-interpolations)[arguments]{#:tests?}: When cross-compiling, set to #false. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org>
-rw-r--r--gnu/packages/julia-xyz.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/julia-xyz.scm b/gnu/packages/julia-xyz.scm
index a4b3fe2a66..6aa185486b 100644
--- a/gnu/packages/julia-xyz.scm
+++ b/gnu/packages/julia-xyz.scm
@@ -2939,7 +2939,8 @@ each one has a fixed size. Currently support inline strings from 1 byte up to
;; Got exception outside of a @test
;; OverflowError: 96908232 * 106943408 overflowed for type Int32
;; Disable as stopgap.
- #:tests? (not (target-x86-32?))))
+ #:tests? (not (or (%current-target-system)
+ (target-x86-32?)))))
(propagated-inputs
(list julia-axisalgorithms
julia-offsetarrays